PrestaShop 1.7.2.3 is now available. This maintenance release fixes 17 issues reported on version 1.7.2.x.

Some of the most notable fixes are:

  • New loading spinner in Product Creation page.
  • New Context mocker for FrontController tests.
  • Fix for a voucher issue.
  • Fix currency display in supply order.
  • Fix cart rules conflict issue.
  • Fix web service product update.

Download PrestaShop 1.7.2.3 now!

Here is the complete list of changes:

  • Back Office:
    • Improvement:
      • #7810: Add a loading spinner into product page
    • Bug fix:
      • #7938: Update bulk action combinations number after delete or add combination
      • #8232: Fixed bug in AdminCartRulesController when limiting the validity …
      • #8287: Fix the category search in the product page
      • #8288: Fix displaying empty zip code of tax rule
      • #8346: Fix the currency display in supply order
      • #8366: Use default country instead of translator locale for marketplace API
  • Front Office:
    • Bug fix:
      • #7781: Add error message when updating quantity wanted input
      • #7848: Fix switching combination when the product is offline
      • #8283: Currency exchange fixes on product page
  • Core:
    • Improvement:
      • #8360: Fixing the version for core modules ps_legalcompliance ps_linklist ps_customtext ps_customeraccountlinks
    • Bug fix:
      • #8213: Voucher issue fix
      • #8298: Add context mocker for front controller tests
      • #8320: Fix again issue on Travis with window maximization (1.7.2.x)
      • #8361: Fix conflict between two cart rules and a single product cart
      • #8380: Fix Context::getTranslator() cache
  • Web Services:
    • Bug fix:
      • #8275: Fix update product with WS

Contributors to this patch version, from both the Core team and the community at large: @aleeks, @christianverardi, @eternoendless, @fatmabouchekoua, @hibatallahaouadni, @prestaworks, @quetzacoalt91, @rgaillard, @tomlev, and @toutantic! Thank you!

Since version 1.7.2.3 is a “patch” update to version 1.7.2.2, upgrading from any 1.7.2 version will be easy: features will work better, and modules & themes which worked fine on 1.7.2.0 will work just as well with 1.7.2.3.
Upgrades from a standard 1.7.x version should work just as well, and those upgrading from older versions (1.6, 1.5, 1.4 or even older) should take their time and pay attention to their modules, their theme and their custom modifications!